import Foundation
let pattern = #"Текст1(?s:.*?)Текстn"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
------
Текст1
Текст2
....
Текстn
------
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)