using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Текст1(?s:.*?)Текстn";
string substitution = @"";
string input = @"------
Текст1
Текст2
....
Текстn
------";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}