$re = '/Текст1(?s:.*?)Текстn/';
$str = '------
Текст1
Текст2
....
Текстn
------';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;