import re
regex = re.compile(r"Текст1(?s:.*?)Текстn")
test_str = ("------\n"
"Текст1\n"
"Текст2\n"
"....\n"
"Текстn\n"
"------")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)