#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "Текст1(?s:.*?)Текстn"
Local $sString = "------" & @CRLF & _
"Текст1" & @CRLF & _
"Текст2" & @CRLF & _
"...." & @CRLF & _
"Текстn" & @CRLF & _
"------"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)