const regex = /Текст1(?s:.*?)Текстn/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Текст1(?s:.*?)Текстn', 'g')
const str = `------
Текст1
Текст2
....
Текстn
------`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);