# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\~(.*)\~|\^\((.*)\)/<sub>\1\2<\/sub>/g;t' <<< "This is a ~text~ to test the results of substitution of ^(text2). This is how it gets"