using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\~(.*)\~|\^\((.*)\)";
string substitution = @"<sub>\1\2</sub>";
string input = @"This is a ~text~ to test the results of substitution of ^(text2). This is how it gets";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}