re = /\~(.*)\~|\^\((.*)\)/
str = 'This is a ~text~ to test the results of substitution of ^(text2). This is how it gets'
subst = '<sub>\\1\\2</sub>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result