import Foundation
let pattern = #"\~(.*)\~|\^\((.*)\)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"This is a ~text~ to test the results of substitution of ^(text2). This is how it gets"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<sub>\1\2</sub>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)