$re = '~\~(.*)\~|\^\((.*)\)~';
$str = 'This is a ~text~ to test the results of substitution of ^(text2). This is how it gets';
$subst = "<sub>\1\2</sub>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;