const regex = new RegExp('\\~(.*)\\~|\\^\\((.*)\\)', 'g')
const str = `This is a ~text~ to test the results of substitution of ^(text2). This is how it gets`;
const subst = `<sub>\1\2</sub>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);