#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\~(.*)\~|\^\((.*)\)"
Local $sString = "This is a ~text~ to test the results of substitution of ^(text2). This is how it gets"
Local $sSubst = "<sub>\1\2</sub>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)