# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^http:\/\/(?:www\.)?(.*)\b$/http:\/\/www.$1/gm;t' <<< "http://example.com
http://foo.example.com
http://who.example.com
http://w.example.com
http://ww.example.com
http://wwooww.example.com
http://wwwoow.example.com
http://wwwoow.myexample.com
http://www.example.com
"