import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^http://(?:www\\.)?(.*)\\b$";
final String string = "http://example.com\n"
+ "http://foo.example.com\n"
+ "http://who.example.com\n"
+ "http://w.example.com\n"
+ "http://ww.example.com\n"
+ "http://wwooww.example.com\n"
+ "http://wwwoow.example.com\n"
+ "http://wwwoow.myexample.com\n"
+ "http://www.example.com\n";
final String subst = "http://www.$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}