re = /^http:\/\/(?:www\.)?(.*)\b$/m
str = 'http://example.com
http://foo.example.com
http://who.example.com
http://w.example.com
http://ww.example.com
http://wwooww.example.com
http://wwwoow.example.com
http://wwwoow.myexample.com
http://www.example.com
'
subst = 'http://www.$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result