#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^http://(?:www\.)?(.*)\b$"
Local $sString = "http://example.com" & @CRLF & _
"http://foo.example.com" & @CRLF & _
"http://who.example.com" & @CRLF & _
"http://w.example.com" & @CRLF & _
"http://ww.example.com" & @CRLF & _
"http://wwooww.example.com" & @CRLF & _
"http://wwwoow.example.com" & @CRLF & _
"http://wwwoow.myexample.com" & @CRLF & _
"http://www.example.com" & @CRLF & _
""
Local $sSubst = "http://www.$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)