package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^http://(?:www\.)?(.*)\b$`)
var str = `http://example.com
http://foo.example.com
http://who.example.com
http://w.example.com
http://ww.example.com
http://wwooww.example.com
http://wwwoow.example.com
http://wwwoow.myexample.com
http://www.example.com
`
var substitution = "http://www.$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}