// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^http://(?:www\.)?(.*)\b$").unwrap();
let string = "http://example.com
http://foo.example.com
http://who.example.com
http://w.example.com
http://ww.example.com
http://wwooww.example.com
http://wwwoow.example.com
http://wwwoow.myexample.com
http://www.example.com
";
let substitution = "http://www.$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}