# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^http://(?:www\.)?(.*)\b$"
test_str = ("http://example.com\n"
"http://foo.example.com\n"
"http://who.example.com\n"
"http://w.example.com\n"
"http://ww.example.com\n"
"http://wwooww.example.com\n"
"http://wwwoow.example.com\n"
"http://wwwoow.myexample.com\n"
"http://www.example.com\n")
subst = "http://www.$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.