use strict;
my $str = 'http://example.com
http://foo.example.com
http://who.example.com
http://w.example.com
http://ww.example.com
http://wwooww.example.com
http://wwwoow.example.com
http://wwwoow.myexample.com
http://www.example.com
';
my $regex = qr`^http://(?:www\.)?(.*)\b$`mp;
my $subst = 'http://www.$1';
my $result = $str =~ s`$regex`$subst`rg;
print "The result of the substitution is' $result\n";