const regex = new RegExp('^http://(?:www\\.)?(.*)\\b$', 'gm')
const str = `http://example.com
http://foo.example.com
http://who.example.com
http://w.example.com
http://ww.example.com
http://wwooww.example.com
http://wwwoow.example.com
http://wwwoow.myexample.com
http://www.example.com
`;
const subst = `http://www.$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);