import Foundation
let pattern = #"^http://(?:www\.)?(.*)\b$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
http://example.com
http://foo.example.com
http://who.example.com
http://w.example.com
http://ww.example.com
http://wwooww.example.com
http://wwwoow.example.com
http://wwwoow.myexample.com
http://www.example.com
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"http://www.$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)