using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^http://(?:www\.)?(.*)\b$";
string substitution = @"http://www.$1";
string input = @"http://example.com
http://foo.example.com
http://who.example.com
http://w.example.com
http://ww.example.com
http://wwooww.example.com
http://wwwoow.example.com
http://wwwoow.myexample.com
http://www.example.com
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}