# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[$]row[[]([^']+?)[\]]/$row['$1']/gm;t' <<< "$row[number]; $row[user];
$row['number']; $row['user'];"