import re
regex = re.compile(r"[$]row[[]([^']+?)[\]]", flags=re.MULTILINE)
test_str = ("$row[number]; $row[user];\n"
"$row['number']; $row['user'];")
subst = "$row['$1']"
result = regex.sub(subst, test_str)
if result:
print(result)