package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[$]row[[]([^']+?)[\]]`)
var str = `$row[number]; $row[user];
$row['number']; $row['user'];`
var substitution = "$row['$1']"
fmt.Println(re.ReplaceAllString(str, substitution))
}