#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)[$]row[[]([^']+?)[\]]"
Local $sString = "$row[number]; $row[user];" & @CRLF & _
"$row['number']; $row['user'];"
Local $sSubst = "$row['$1']"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)