$re = '/[$]row[[]([^\']+?)[\]]/m';
$str = '$row[number]; $row[user];
$row[\'number\']; $row[\'user\'];';
$subst = "$row['$1']";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;