import Foundation
let pattern = #"[$]row[[]([^']+?)[\]]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
$row[number]; $row[user];
$row['number']; $row['user'];
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$row['$1']"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)