using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[$]row[[]([^']+?)[\]]";
string substitution = @"$row['$1']";
string input = @"$row[number]; $row[user];
$row['number']; $row['user'];";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}