use strict;
my $str = '$row[number]; $row[user];
$row[\'number\']; $row[\'user\'];';
my $regex = qr/[$]row[[]([^']+?)[\]]/mp;
my $subst = '$row[\'$1\']';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";