const regex = /[$]row[[]([^']+?)[\]]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[$]row[[]([^\']+?)[\\]]', 'gm')
const str = `\$row[number]; \$row[user];
\$row['number']; \$row['user'];`;
const subst = `$row['$1']`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);