#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)__(.*?)\s*__\s*"
Local $sString = "__underline a sentence __and more." & @CRLF & _
"__underline a sentence__ and more."
Local $sSubst = "<u>$1</u> "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)