using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"__(.*?)\s*__\s*";
string substitution = @"<u>$1</u> ";
string input = @"__underline a sentence __and more.
__underline a sentence__ and more.";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}