const regex = /__(.*?)\s*__\s*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('__(.*?)\\s*__\\s*', 'gm')
const str = `__underline a sentence __and more.
__underline a sentence__ and more.`;
const subst = `<u>$1</u> `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);