package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)__(.*?)\s*__\s*`)
var str = `__underline a sentence __and more.
__underline a sentence__ and more.`
var substitution = "<u>$1</u> "
fmt.Println(re.ReplaceAllString(str, substitution))
}