import re
regex = re.compile(r"__(.*?)\s*__\s*", flags=re.MULTILINE)
test_str = ("__underline a sentence __and more.\n"
"__underline a sentence__ and more.")
subst = "<u>$1</u> "
result = regex.sub(subst, test_str)
if result:
print(result)