re = /__(.*?)\s*__\s*/m
str = '__underline a sentence __and more.
__underline a sentence__ and more.'
subst = '<u>$1</u> '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result