import Foundation
let pattern = #"__(.*?)\s*__\s*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
__underline a sentence __and more.
__underline a sentence__ and more.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<u>$1</u> "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)