use strict;
my $str = '__underline a sentence __and more.
__underline a sentence__ and more.';
my $regex = qr/__(.*?)\s*__\s*/mp;
my $subst = '<u>$1</u> ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";