// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)__(.*?)\s*__\s*").unwrap();
let string = "__underline a sentence __and more.
__underline a sentence__ and more.";
let substitution = "<u>$1</u> ";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}