$re = '/__(.*?)\s*__\s*/m';
$str = '__underline a sentence __and more.
__underline a sentence__ and more.';
$subst = "<u>$1</u> ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;