#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\/required\/)(?:identifier\/optional1\/optional2\/)(.*)"
Local $sString = "/required/identifier/optional1/optional2/some_last_dir_1" & @CRLF & _
"/required/identifier/optional1/optional2/some_last_dir_2"
Local $sSubst = "$1$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)