$re = '/(\/required\/)(?:identifier\/optional1\/optional2\/)(.*)/m';
$str = '/required/identifier/optional1/optional2/some_last_dir_1
/required/identifier/optional1/optional2/some_last_dir_2';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;