import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\/required\\/)(?:identifier\\/optional1\\/optional2\\/)(.*)";
final String string = "/required/identifier/optional1/optional2/some_last_dir_1\n"
+ "/required/identifier/optional1/optional2/some_last_dir_2";
final String subst = "$1$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}