// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\/required\/)(?:identifier\/optional1\/optional2\/)(.*)").unwrap();
let string = "/required/identifier/optional1/optional2/some_last_dir_1
/required/identifier/optional1/optional2/some_last_dir_2";
let substitution = "$1$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}