const regex = /(\/required\/)(?:identifier\/optional1\/optional2\/)(.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\\/required\\\/)(?:identifier\\\/optional1\\\/optional2\\\/)(.*)', 'gm')
const str = `/required/identifier/optional1/optional2/some_last_dir_1
/required/identifier/optional1/optional2/some_last_dir_2`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);