package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\/required\/)(?:identifier\/optional1\/optional2\/)(.*)`)
var str = `/required/identifier/optional1/optional2/some_last_dir_1
/required/identifier/optional1/optional2/some_last_dir_2`
var substitution = "$1$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}