re = /(\/required\/)(?:identifier\/optional1\/optional2\/)(.*)/m
str = '/required/identifier/optional1/optional2/some_last_dir_1
/required/identifier/optional1/optional2/some_last_dir_2'
subst = '$1$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result